品易云推流 关闭
文章详情页
文章 > PHP教程 > php有哪些文件包含漏洞

php有哪些文件包含漏洞

头像

小妮浅浅

2021-05-27 15:28:22771浏览 · 0收藏 · 0评论

1、LFI

本地文件包含漏洞,顾名思义,指的是能打开并包含本地文件的漏洞。大部分情况下遇到的文件包含漏洞都是LFI。

2、RFI

远程文件包含漏洞。是指能够包含远程服务器上的文件并执行。由于远程服务器的文件是我们可控的,因此漏洞一旦存在危害性会很大。但RFI的利用条件较为苛刻,需要php.ini中进行配置。

allow_url_fopen = On

3、实例

<?php
$file = $_GET['file'];
include $file;
?>

allow_url_fopen 默认为 Onallow_url_include 默认为 Off

 若有特殊要求,会在利用条件里指出。

以上就是php文件包含漏洞的介绍,希望对大家有所帮助。更多php学习指路:php教程

关注

关注公众号,随时随地在线学习

本教程部分素材来源于网络,版权问题联系站长!

底部广告图