品易云推流 关闭
文章详情页
文章 > Python基础教程 > python poetry如何安装依赖

python poetry如何安装依赖

Python poetry

头像

小妮浅浅

2021-09-25 09:37:231356浏览 · 0收藏 · 0评论

在创建了虚拟环境之后,就可以安装依赖了。

1、直接使用poetry的add命令来安装依赖,其中有-dev表示他是开发环境依赖包。

开发环境依赖包和生成环境依赖包是非常有益的。

➜ poetry add flask
➜ poetry add pytest --dev

2、pyproject.toml在安装依赖后可以看到变更文件。

...
[tool.poetry.dependencies]
python = "^3.7"
Flask = "^1.1.2"
 
[tool.poetry.dev-dependencies]
pytest = "^6.2.4"
...

以上就是python poetry安装依赖的方法,希望对大家有所帮助更多Python学习指路:python基础教程

本文教程操作环境:windows7系统、Python 3.9.1,DELL G3电脑。

关注

关注公众号,随时随地在线学习

本教程部分素材来源于网络,版权问题联系站长!

底部广告图