技术文章 > Python技术 > Python基础 > 正文

python无法安装pil是什么原因

FXL

python无法安装pil的原因:pil只支持python2版本。解决方法:可以安装替代包Pillow。首先打开命令提示符;然后执行【pip install Pillow】命令,等待安装完成即可。

python3无法正常安装PIL,因为PIL只支持python2各个版本,还没有python3的版本。

(推荐教程:Python入门教程

首先我们进入PIL官网;

http://www.pythonware.com/products/pil/

6aab0adc6c72fb5bbba506c87de734f.png

可以看出pil只支持python2各个版本。

不过有一个可以替代PIL的包,并且可以在python3上正常安装。

安装方法:

1、打开命令提示符;

2、执行如下命令即可;

pip install Pillow

7068883174849515d840a6b9e00a81a.png

免费视频教程
本文原创发布python学习网,转载请注明出处,感谢您的尊重!
相关文章
 python中如何使用pil
 python中pil如何导入?
 python中无法引入pil怎么解决
 pycharm无法安装pil怎么办?
相关视频章节
 解决提示“‘python’不是内部或外外部命令
 python代码缩进
 python编码规范
 python命名规范
视频教程分类