技术文章 > Python技术 > Python基础 > 正文

tornado支持python3吗

爱喝马黛茶的安东尼

Tornado最新发布5.1版本,并推迟了发行Tornado 6.0主版本的计划。Tornado是一个基于Python的Web框架,由异步网络库组成,用于在Python中进行完整的Web开发。它以在网络上扩展大量连接的能力而闻名,是开发需要在Web上保持连接不间断的应用程序的理想选择。

Tornado 5.1中包含的功能有:

    ·命令行包装器的改进,不再与Windows上的活动进程冲突;

    ·新模块支持用户名和密码中的非ASCII字符;

    ·客户端-服务器模块一致,如simple_httpclient和curl_httpclient;

    ·改善了与GNU Hurd的兼容性;

    ·改进了WebSocket模块,以防止DoS攻击;

    ·嵌入Tornado 6.0的部分功能。

Tornado 6.0将放弃对Python版本2.7和3.4的支持,同时将Python 3.5.2作为最低支持版本。为确保在较旧的Python版本上运行的系统不会中断,将发出弃用警告。要接收弃用警告,您需要运行-wd参数,或为Python生态系统设置环境变量。

python学习网,免费的在线学习python平台,欢迎关注!

免费视频教程
本文原创发布python学习网,转载请注明出处,感谢您的尊重!
相关文章
 十分钟学会web开发利器之tornado
 Python3爬虫利器:Tornado的安装
相关视频章节
 3tornado在Linux的环境安装
视频教程分类